Documentation

Update on Visa’s EMV 3D Secure Requirements: No Action Needed for Our ePDQ Customers

A recent communication from Barclaycard has highlighted upcoming changes to Visa’s EMV® 3D Secure (EMV 3DS) requirements, specifically regarding the mandatory data fields in the 3DS Authentication Request (AReq) message. This guide aims to reassure our ePDQ customers that our plugins already support these changes, ensuring there’s nothing you need to do to comply with these new requirements.

Understanding the Visa EMV 3DS Update

Visa is set to enhance the security of e-commerce payments by updating the mandatory data fields required for EMV 3DS authentication. This change, effective from 12 August 2024, aims to reduce card-not-present (CNP) fraud and improve the authentication process. The update includes making certain browser and in-app data fields mandatory, such as the browser IP address, screen dimensions, cardholder email address or phone number, cardholder name, and common device identification parameters.

Why This Change Matters

The addition of these data fields allows for more accurate authentication decisions by card issuers, leading to:

  • Higher authentication success and approval rates.
  • A smoother customer experience with improved frictionless authentication.

Our ePDQ Plugin Compliance

We want to assure our ePDQ customers that our plugins have been proactively updated to support these new EMV 3DS requirements. Here’s why you can rest easy:

  • Pre-emptive Support: Our development team has ensured that all mandatory and recommended data fields outlined by Visa are already integrated into our ePDQ plugin.
  • Seamless Integration: There’s no need for any action on your part. Our plugin automatically handles the necessary data fields for EMV 3DS authentication.
  • Continued Compliance: We are committed to maintaining up-to-date compliance with payment industry standards, ensuring your transactions remain secure and efficient.

No Action Required for ePDQ Customers

For our ePDQ plugin users, there is no need to be concerned about the upcoming Visa EMV 3DS changes. Our plugin is fully prepared to meet these requirements, ensuring your payment processes remain uninterrupted and fully secure. You do not need to contact your web developer or make any adjustments to your current setup.

The upcoming Visa EMV 3DS requirements mark a significant step towards enhancing the security of e-commerce payments. With the proactive adaptations made to our ePDQ plugin, you can rest assured that your payment processes will continue without interruption, fully secure and compliant with these new standards. We are committed to providing secure, efficient, and compliant payment solutions, ensuring that your business is always at the forefront of payment security advancements.

Should you have any questions or require additional information, our support team is readily available to assist. We’re here to support your WooCommerce success and ensure your peace of mind with secure and seamless payment transactions.

FAQs

Q: Do I need to manually update my ePDQ plugin to comply with these changes?
A: Yes, please ensure your ePDQ plugin is always updated to the latest version. This is vital for incorporating the necessary changes related to this email notice and maintaining compliance.

Was this helpful?

Barclays ePDQ

Don't already have the plugin? Get access now.

Still need help?

Our team are on hand to provide fast, helpful and professional support.

Support request

Front End Demo

Test drive our plugin on the demo site.

View Demo

AG Bot (BETA)

Ask our bot about our products.

Welcome to our AG Bot, powered by OpenAI and trained on our documents and product pages. By continuing to use this service, please keep in mind:

Your continued use indicates acceptance of these terms. We hope you find our AI Chatbot useful!

Hello! I am AG Bot, how can I help you?