Documentation

Plugin requirements for Tyl by NatWest for WooCommerce

If you’re wondering what are the minimum and recommended server settings requirements for Tyl by NatWest for WooCommerce, this article is for you.

WordPress

Keeping your WordPress platform up-to-date is crucial for maintaining the security and compatibility of your website. As a plugin provider, we regularly check our plugins with the latest versions of WordPress to ensure optimal performance. We highly recommend updating to the latest version of WordPress whenever possible, but please note that our plugins are tested with WordPress version 6.0+.

WooCommerce

Our plugins require WooCommerce, and we recommend using the latest version of WooCommerce for optimal performance. We also regularly check our plugins with the latest versions of WooCommerce to ensure compatibility. The minimum version of WooCommerce required is 7.1+.

PHP & Server Settings

Your website’s PHP version and server settings are critical factors that can affect your site’s security and performance. We recommend using a server with PHP version 8.1 or higher to ensure optimal performance and security. Before setting up a website on WordPress, we also suggest checking the platform’s requirements.

Regarding server settings, there is no specific minimum requirement as long as your server can handle the actions performed by our plugins or any other active plugins on your site. Typically, a standard hosting package should suffice. However, since our plugins require WooCommerce, we recommend checking their article on server recommendations as well. At our end, we regularly check our plugins with the latest versions of WordPress, WooCommerce & PHP versions to ensure compatibility and optimal performance.

We hope that this information helps! Let us know if you need further assistance or clarifications by contacting our support and our team will be glad to provide you more information and help with your queries.

Was this helpful?

Tyl by NatWest

Don't already have the plugin? Get access now.

Still need help?

Our team are on hand to provide fast, helpful and professional support.

Support request

Back End Demo

Start exploring our fully functional demo site today.
Gain exclusive admin access to see what's possible.

Create your demo now

Front End Demo

Test drive our plugin on the demo site.

View Demo

AG Bot (BETA) - Not live chat

Ask our bot about our products.

Welcome to our AG Bot, powered by OpenAI and trained on our documents and product pages. By continuing to use this service, please keep in mind:

Your continued use indicates acceptance of these terms. We hope you find our AI Chatbot useful!

Hello! I am AG Bot, how can I help you? (Not live chat)